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1 Overview 
AxiaManager Scope (short: AM Scope) is an integrated oscilloscope software that offers an 
advanced view of selected tracks. 

− You can record tracks of selected parameters and collect unlimited sampled for up to 
8 tracks at a time. This helps you to analyze commissioning errors and make an easy 
troubleshooting of your application setup. 

− You can visualize up to 8 tracks simultaneously at high frequency and trigger solu-
tion. This helps you to supervise and fine-tune commissioning parameters and control 
loops. 

AxiaManager Scope can be started as a separate software or be opened from within 
AxiaManager. 
 

1.1 Possible actions 

Record tracks 

 

You can visualize single sequences of up to 
8 parameters. 

Capture tracks continuously 

 

You can capture 8 tracks continuously for 
future analyzation, printing or export. 

Adapt graph view to personal needs 

 

You can show or hide grids, measure bars, 
split tracks and zoom in and out horizontally 
and vertically to obtain all the information 
you need. 

Display triggers 

 

You can display the value of selected tracks 
at runtime, without the need of stopping the 
application. 
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1.2 Introduction to the User Interface 
The figure below shows a view of AxiaManager Scope’s workspace, including many of its more 
commonly used components. 
 

 
 

1 Menu Bar and Toolbar 2 Graph window 
3 Graph controls 4 Acquisition controls 
5 Status bar 6 Output window 
7 Watch window 8 Parameters window 

 

The following paragraphs give an overview of these elements. 
 

1.2.1 The Menu Bar and the Toolbar (1) 

 
 

AxiaManager Scope allows the user to hide or show the main toolbar to fully customize the 
workspace. Each operation in the environment, to realize a program, can be performed 
through the menu bar; the toolbar contains icons which work as shortcut for the menu’s 
commands (  6.3 and 6.4). 
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1.2.2 The Graph Window (2) 
The Graph window shows the graphs and tracks of the selected parameters is always visible.  

 
 

The Graph window is the main window in AxiaManager Scope and will always be shown. It 
cannot be hidden via the View menu. The monitored tracks are shown in the lower bar of this 
window. 
 

1.2.3 The Graph Controls (3) 

 
 

You can personalize the view of the graph window: Show or hide grids, measure bars, split 
tracks and zoom in and out horizontally and vertically. 
 

1.2.4 The Acquisition Controls (4) 

 

 
 

You can make acquisitions of an unlimited number of samples related to up to 4 tracks  
(  4.5). 
Save, print and export tracks for offline analyzation (  5). 
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1.2.5 The Status Bar (5) 
The Status bar displays the connection status of the application with the target device at its 
right border. 
 

 
 

If you have not yet attempted to connect to the target, the status of communication is set to 
Disconnected. 
When you try to connect to the target device, the state of communication becomes one of the 
following: 

− Connected: the communication has been correctly established. 
 

− Error: the communication cannot be established. You should check both the physical 
link and the communication settings. 

 
 

1.2.6 The Output Window (6) 
The Output window (6) is the place where AxiaManager Scope prints its output messages. 
 

 
 

1.2.7 The Watch Window (7) 
The Watch window is one of the debugging tools supplied by AxiaManager Scope. Among the 
other debugging tools in AxiaManager, it is worth mentioning the graphs, the triggers, and the 
debug log. 
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1.2.8 The Parameters Window (8) 
The Parameters window consists of two distinct panels, as shown in the following picture. 
 

  
 

1.2.8.1 Parameters 
The Parameters panel contains all the elements of the project, visualized in a tree-like 
organization. Custom folders (Favorites) can be added to the project tree in order to reorganize 
the elements accordingly to the user preferences. 
 

1.2.8.2 PLC symbols 
The content of the PLC symbols panel depends on how the target device is interfacing with 
AxiaManager Scope: it may include configuration elements, schemes or wizards. 
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2 Using the Environment 
This chapter shows you how to deal with the UI elements AxiaManager Scope is composed of, 
in order to let you set up the oscillator in the way which best suits to your specific development 
process. 
 

2.1 Conventions Used in This Document 
Text Type Description 

Command, Key Name of the command or keyboard shortcuts key 

 Menu>Item  For menu items hierarchy, the “>” symbol is used. A record File>Open 
Project is equivalent to “the Open Project item under the File menu”. 

 …  Link to related subject within this guide. 

 …  Link to related subject in an external guide. 

Terminology Important term or concept. 

0x1234 Representation of parameter numbers 

Parameter/Object Representation of parameter names 

01234 Representation of parameter values/object settings 
 

2.2 Customize the Layout 
The layout of AxiaManager Scope’s workspace can be freely customized in order to suit your 
needs. 
AxiaManager Scope takes care to save the layout configuration on application exit, in order to 
persist your preferences between different working sessions. 
 

2.2.1 Show/Hide the Toolbar 
In details, in order to show (or hide) the toolbar, open the View>Main toolbar menu. 
The toolbar is then shown (hidden). 
 

 
 

2.2.2 Move the Toolbar 
You can move the toolbar by clicking on its left border and then dragging and dropping it to 
the destination. 

 
The toolbar shows up in the new position. 
 



Preliminary  
 

 

04/24 AxiaManager Scope 9 
 

2.2.3 Show/Hide Tool Windows 
The View  menu allows you to show (or hide) a tool window (for example, the Output window, 
the Parameters panel, the Watch window … ). The window is then shown (hidden). 
 

2.2.4 Floating Tool Windows 
You can undock any window from its default location in AxiaManager Scope and move it 
anywhere, just click on its title bar and drag it to the location you want. 

 
 

Take back a window to its most recent docked location simply double-click the title bar of the 
window. 
 

2.2.5 Docking Tool Windows 
AxiaManager Scope shows you a guide diamond when you drag a window to another location 
to help you easily re-dock the window. 
While dragging a window move the mouse cursor on the position of the guide diamond you 
want to use as new window position. 

 
 

Tool windows can be fastened to one side of a frame in AxiaManager Scope or within a frame. 
 

2.2.6 Auto-Hide Tool Windows 
By the pin button on the top right corner of the window you can switch the window to auto-
hide mode or to regular docking mode. 
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2.2.7 Merge Several Windows in One 
To achieve a clearer arrangement of the workspace it is possible to merge several tool windows 
into one. E.g.: Drag the Output window and drop it into the Monitor window. 

 
In the resulting combined window click on the tab in the bottom left corner to choose the 
desired window. 

 

2.3 Change the Language 
If you click Options>Change Language  menu you can change the language of the 
environment by selecting a new one from the list shown in this panel. 

 
 

After selecting the new language, confirm by the clicking OK button. This change will be 
effective only the next time you start AxiaManager Scope. 
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3 Configuring Communication to the Inverter 
If you started AxiaManager Scope from the AxiaManager the connection is taken over. To set 
up the communication see  VEC1en51 AXIAManager GUI Manual. 
 

 
• Press the Communication settings icon in the toolbar to change the 

communication. 
Alternatively, you can go to Connection > Configure communication … or 
press the button F12. 

 • Change the settings as needed (  VEC1en51 AXIAManager GUI 
Manual). 

 
• Press the Connect icon or button F11 to connect the inverter. 
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4 Using the Oscilloscope 
The Oscilloscope allows you to plot the evolution of the values of a set of parameters. The 
Oscilloscope consists of six elements, as shown in the following picture. 
 

 
 

1 Chart area 2 Graph controls window 
3 Acquisition controls window 4 Scroll bar 
5 Tracks area 6 Cursors 

 

The Chart area (1) and the Tracks area (5) are always visible. The Graph controls (2) and 
Acquisition control windows (3) can be shown of hidden as described in chapter 2.1. 
 

Chart area (1) 
This area shows the graphs of the selected tracks. It includes several items: 

− Plot: area containing the curve of the tracks. 
− Cursors (6) identifying up to four distinct vertical of horizontal lines. The values of 

each track at the intersection with these lines are reported in the corresponding col-
umns. 

− Scroll bar (4): If the scale of the x-axis is too large to display all the samples in the 
chart area, the scroll bar allows you to slide back and forth along the horizontal axis. 

 

Graph controls window (2) 
In this window you can make visual adaptations to the charts in the Oscilloscope. A detailed 
description of the function of each control is given in chapter 4.5. 
 

Acquisition control window (3) 
In this window you to control all parameters for the data acquisitions. A detailed description 
of the function of each control is given in chapter 4.5. 
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Tracks area (5) 
The lower section of the Oscilloscope is a table consisting of a row for each selected track. 
Each row has several columns, as shown in the picture below. 
 

 
 

Column Description 
Track Name of the variable 
Address  
Unit Unit of measurement 
Cur value Current value of the variable 
Min value Minimum value in the record set 
Max value Maximum value in the record set 
Avg value Average value in the record set 
Value/Div How many engineering units are represented by a unit of the y-axis  

(i. e. the space between two ticks on the vertical axis). 
Description Information about the variable in watch, like its parent POU and the execution task 

 

4.1 Sampling Tracks 
4.1.1 Normal Operation 
The Oscilloscope manager periodically reads from memory the value of the tracks. However, 
this action is carried out asynchronously, that is, it may happen that a higher-priority task 
modifies the value of some of the tracks while they are being read. Thus, at the end of a 
sampling process, data associated with the same value of the x-axis may actually refer to 
different execution states of the PLC code. 
 

4.1.2 Target Disconnected 
If the target device is disconnected, the curves of the dragged-in tracks get frozen, until 
communication is restored. 
 

4.2 Add a Track from the Parameters Panel 
In order to plot the evolution of the value of a parameter, you need to add it to the 
Oscilloscope. To add a parameter, you can select it in the Parameters panel and then drag-
and-drop it into the chart area or the tracks area. 
 

 
 

 Drag-and-drop function 
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Alternatively, you can click on Edit> Add custom track (or Ctrl+T) to add a track to the 
Oscilloscope. This function is useful if you are looking for a specific track and do not find it in 
the parameters panel. 
• Select a track type from the drop-down menu. 

 
 

• Insert any information that you know about the track (virtual track, physical or relative 
address, data block, dictionary object) and click on Add Track. 

 
 

 

4.3 Remove a Track 
If you want to remove a track from the Oscilloscope, select it by clicking on its name once, 
then press the Del key. 
 

 
 

Alternatively, select the track you want to remove from the Oscilloscope and click on 
Edit>Remove selected track. 
To remove all tracks from the Oscilloscope click on Edit>Remove all trigger source tracks. 
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4.4 Adapt View Preferences 
The Graph Control window includes commands, which can be used to adapt the way graphs 
are displayed. 

 
 

Icon Command Description 

 
Toggle grid Choose whether to display or not the Toggle grid in the oscilloscope 

window (  4.4.1) 

 
Show measure bars Show or hide measure bars in the oscilloscope window  

(  4.4.2). 

 
Show acquisitions Highlight the single values detected during data acquisition  

(  4.4.3) 

 
Vertical split Split the graph view to show the graphs in single windows  

(  4.4.4) 

 
Show all values  4.4.5 

 
Undo zoom settings 

 4.5.5 

 
Horizontal zoom in 

 
Horizontal zoom out 

 
Horizontal show all 

 
Vertical zoom in 

 
Vertical zoom out 

 
Vertical show all 

 
View graph settings You can set the scale of the axes (  4.4.6) 

 

In the Graph  menu more functions are available: 
 

Command Description 
Dynamic grid Activate/deactivate the dynamic grid function in the oscilloscope 

window (  4.4.1). 

Show all values for selected 
track 

 4.4.5 
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4.4.1 Set the Grid Options 
Toggle grid 
You can customize the appearance of the Oscilloscope by clicking on the Toggle grid icon in 
the Graph controls window. 
 

 
You can choose whether to display or not the Toggle grid. 
 

 

Dynamic grid 
You can adapt the vertical scale of the grid to make it display the values corresponding to the 
curves shown in the graph. 
Click on Graph>dynamic grid to activate/deactivate the dynamic grid function. 

 
 

The dynamic grid function displays the exact values of single peaks of the curves, making it 
easier to read the scale. 
 

4.4.2 Take Measures 
The Oscilloscope includes a measure bar, which can be exploited to take some measures on 
the chart; in order to show and hide them, click on the Show measure bars icon in the Graph 
control window. 
 

 
If you want to measure a time interval between two events, you just have to 
move one bar to the point in the graph that corresponds to the first event and 
the other to the point that corresponds to the second one. 

 

Vertical cursors 

 
 

The time interval between the two bars is shown in the top left corner of the chart. 
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You can use a measure bar also to read the value of all the tracks in the Oscilloscope at a 
particular moment: Move the bar to the point in the graph which corresponds to the instant 
you want to observe. 
In the table below the chart, you can now read the values of all the tracks at that particular 
moment. 
 

 
 

Column Description 
V Blue cursor Value of the variable at the intersection with the line identified by the vertical blue cursor 
V Red cursor Value of the variable at the intersection with the line identified by the vertical red cursor 

 

In addition to the vertical bar, by enabling the measure bars, you will also find two horizontal 
bars on the right of the grid. They work the same way of the vertical bars, but they take values 
on the vertical axis. 
Horizontal cursors 
Like the vertical bars, also the horizontal bars have their values displayed for every track in 
the table below the chart. 

 
 

Column Description 
H Red cursor Value of the variable at the intersection with the line identified by the horizontal red cursor 
H Blue cursor Value of the variable at the intersection with the line identified by the horizontal red cursor 
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4.4.3 View Samples 
 

 
If you click on the Show acquisitions icon, the tool highlights the single values 
detected during data acquisition. 

 

 
 

You can click on the same icon again, in order to go back to the default view mode. 
 

4.4.4 Split Tracks 
 

 
When you are watching the evolution of two or more tracks, you may want to 
split the respective tracks. For this purpose, click on the Vertical split icon in the 
Oscilloscope toolbar. 

 

      
 

To separate traces you can also manually move them; to do so grab the corresponding-colored 
flag on the left of the chart and drag it to the desired location. 
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4.4.5 Change the Zoom 
In the Oscilloscope toolbar you can also find icons for zoom in and out, and also to force the 
Oscilloscope to display all the samples. 
 

 

 

 

These options are axis-related, so you can zoom in, zoom out and show all 
samples for the horizontal axis alone. 
The horizontal zoom functions apply to all actual tracks shown in the scope. 

 

 

 

 

You can zoom in, zoom out and show all samples for the vertical axis alone. 
The vertical zoom functions apply to the track selected in the tracks area. 

 

 
Click on the Undo Zoom settings icon to reverse your latest changes of the zoom 
view step by step. 

 

Zoom in by marking an area 
An easy way to zoom in for a specific detail is to drag a rectangle with the left mouse-button 
in the graphic display. Release the mouse-button and the display will zoom into the selected 
area. 
 

Show all values 

 
You can also quickly force the oscilloscope to display all samples for both 
horizontal and vertical axis (which means show all values) with this icon. 

 

Show all values for selected track 
To force the oscilloscope to display the samples of a single track, select the track and click 
Graph>Show all values for selected track . 
 

4.4.6 Set the Scale of the Axes 
 

 
When you open the Oscilloscope, AxiaManager Scope applies a default scale to 
the axes. However, if you want to set a different scale, you can do that by 
opening the Graph Settings by clicking on the corresponding icon in the toolbar. 

 

The Graph Settings window will open, allowing you to change both the vertical and the 
horizontal axis as well as further graphical settings. 
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Show grid 
Tick this control to display a grid in the Chart area background. 
 

Show time bar 
The scroll bar at the bottom of the Chart area is available as long as this box is checked. 
 

Show tracks list 
The Variables window is shown as long as this box is checked, otherwise the Chart area 
extends to the bottom of the graphic trigger window. 
 

Horizontal scale 
The horizontal scale is the same for all active tracks. ms/DIV specifies the time base (here 
3102.9 ms/DIV). This value refers to the number of samples per unit of the x-axis. By unit of 
the x-axis the space is meant between two vertical lines of the background grid. 
The timeline can be adjusted with the parameters Time reference and Time display. 
 

Tracks list 
In the tracks list you can set the colors of each track, the vertical scale and the offset value. 
The vertical scale can be different for every track, you can specify the desired scale in the 
edit box labeled Value/div. This parameter determines the scaling of the signal on the display. 
Its value is always referenced to the defined physical units of the signal. Special handling 
applies to boolean signals, indicated with "B". The boolean value FALSE is always displayed as 
0.0, the boolean value TRUE is always displayed as 1.0. 
 

Unit 
Unit of measurement, printed in the table of the Variables window. 
 

Value/div 
Δ value per unit of the y-axis. By unit of the y-axis is meant the space between two horizontal 
lines of the background grid. 
The offset is set in absolute numbers and is always referenced to the defined physical unit of 
the parameter. The value of the desired offset can be entered directly and accepted with 
ENTER. 
The color of the displayed signal is set with the color dropdown menu. 
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Hide 
Check this flag to hide selected track on the graph. 
 

• Press Apply to make your changes effective, or press OK to apply your changes and to 
close the options tab. 

 

4.5 Control the Data Acquisition 
The Acquisition Control window includes commands, which can be used to control the 
acquisition process. This paragraph focuses on these commands. 
Note that all the commands in the toolbar are disabled if no track has been added to the 
Oscilloscope. 
 

 

 

 
 

Icon Command Description 

 
Run/stop acquisition Starts/stops the track acquisition. 

 
Stop acquisition display Stops the graph display. 

 
Pause acquisition display Lets you pause the graph display. 

 
Start acquisition display The currently acquired data is displayed in the chart area. 

 

In the Acquisition  menu more functions are available: 
 

Command Description 
Download last acquisition Lets you download your last acquisition. 
Continuous capture Selects the acquisition mode Continuous capture (  4.5.3). 

Single sequence capture Selects the acquisition mode Single sequence capture (  4.5.3). 

Auto trigger mode Selects the Auto trigger mode (  4.5.2). 

Normal trigger mode Selects the Normal trigger mode (  4.5.2). 

Force trigger Selects the Force trigger function (  4.5.2). 

Import project from target Reloads all remote logs from target (  4.5.7). 
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4.5.1 Start and Stop Data Acquisition 
 

 
Run/stop acquisition: 
When you add a parameter to the Oscilloscope via drag-and-drop, data 
acquisition begins immediately. Alternatively, you can start the acquisition by 
clicking on Acquisition>Run acquisition or press F3. 
The acquisition status changes from “Idle” to “Recording”. 
Note that the graph display is only displaying the track when you start acquisition 
display. 

 

 
Start acquisition display: 
If you press this button the acquisition becomes visible in the chart area. 

 

 
Pause/restart acquisition display: 
You can suspend the acquisition by clicking this button. The curve freezes (while 
the process of data acquisition is still running in background), until you click this 
button again. 

 

 
Stop acquisition display: 
To stop the graph click on this button. 

 

In this case, when you click on Restart acquisition, the evolution of the value of the parameter 
is plotted from scratch. 
 

4.5.2 Select Trigger Mode: 
In order to trigger on an event, the data acquisition must be activated with Run/Stop 
Acquisition button. 

 
 

Trigger mode: 
The trigger mode can be selected in the Acquisition menu. Select either Auto trigger mode or 
Normal trigger mode. 
 

Auto (automatically selected if no Trigger source is selected) 
In the Auto trigger mode, a new display is shown with each filling of the buffer. 
 

Normal (automatically selected if a Trigger source is selected) 
In Normal trigger mode a new display is generated after the trigger has occurred and the 
storage buffer completely filled. 
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4.5.3 Select Acquisition Mode 
 

 
 

The acquisition mode can be either selected by a mouse click on the button to the right of the 
“Acquisition mode” text or in the Acquisition menu. Select either Single sequence capture or 
Continuous capture. 
 

Single 
(automatically selected if realtime mode is set to Disabled) 
For the Single sequence capture mode of operation, the buffer is completely filled once after 
the occurrence of the trigger incident and then the display updated. 
If you intend to use the trigger function (see chapter 4.5.6), the Acquisition mode should be 
set to “Single”. 
 

Continuous 
(automatically selected if realtime mode is set to Enabled) 
In Continuous capture mode the display runs through continuously and the current acquired 
data is visible in the display. The screen can be started/stopped with the Run/Stop data button. 
If the buffer is full, the oldest data are deleted and replaced with current new data. 
 

4.5.4 Select Realtime Mode 
The Realtime mode can be selected by a mouse click on the button to the right of the “Realtime 
mode” text. 
Disabled 
In order to be able to use the trigger function, the Realtime Mode has to be disabled. By 
entering a Trigger source (see chapter 4.5.6) other than “none”, the Realtime Mode switches 
to “Disabled” automatically. 
If you set the Realtime mode to disabled, the Acquisition mode will switch to Single.  
 

Enabled 
If you set the Realtime mode to enabled, the Acquisition mode will switch to Continuous., 
but can be changed back to Single manually. 
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4.5.5 Set Acquisition Time 

 
 

Tracks supported 
This is a display panel showing the max. number of supported tracks. The value is depending 
on the transmission speed of the connection (USB or Bluetooth) and the number or tracks. 
 

Sample time base 
This is a display panel showing the sample time actually possible. The value is depending on 
the transmission speed of the connection and the number or tracks. The Sample time base 
can be changed in the Time prescaler entry field. 
 

Time prescaler 
Set a time prescaler in this entry field to determine the acquisition time. The prescaler is a 
factor which influences the value in the Acquisition time. entry field. If the Sample time base 
is 0.0625 ms and you enter the factor “10”, the sample time base changes to 0.625 ms. 
 

Max. acquisition time 
This display panel shows the max. available acquisition time. The value is depending on the 
number of the variables you want to watch. The number in this field represents the maximum 
time you can collect samples for each variable. 
 

Acquisition time 
Displays the length of the acquisition. The max. acquisition time is shown in the above display 
panel. The recording stops the acquisition, whenever the buffer has been completely filled. 
 

4.5.6 Select Trigger Source 

 
 

Select the track for which triggering is to be carried out. The drop-down menu offers the 
selection of a track added to the track area. 
Selecting a track causes the trigger mode to change from Auto mode to Normal mode. Auto 
mode is only possible if you select trigger source none. 
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Trigger slope 

 
 

The setting of the trigger edge positive/negative is carried out with the Falling / Rising 
selection. 
Trigger value 
In this entry field you can enter the trigger level. When the trigger source exceeds this level 
the acquisition will start. The possible setting value is referred to the unit of the selected track. 
The value 0 refers to the zero point of the selected track. 
 

Pre-trigger time 
Here, you can enter a time span before the trigger. This makes it possible to make the track 
visible before the trigger value was exceeded. 
 

Samples acquired 
This display panel shows the number of samples acquired. 
 

Status 
This read-only display shows the state of the Trigger function. It can assume the following 
values. 
 

 
System is not triggering. Triggering has not been started yet or it has been 
stopped by user or a halt condition has been reached. 

 
No samples taken, as the trigger has not occurred during the current 
acquisition. 

 
Samples collected, as the trigger has occurred during the current acquisition. 

 
Sample(s) collected, as the trigger has occurred during the current task 
execution. 

 
The acquisition has started. 

 

The Samples acquired display indicates that a number of samples has been 
collected satisfying the user request or memory constraints, thus the 
acquisition process is stopped. 

 
Communication with target interrupted. The state of the trigger cannot be 
determined. 
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Example: 
Let us say you intend to acquire the Speed parameter from the point when it rises above 
500 rpm. You also want to see how the speed curve acted 100 ms before it exceeded the 
threshold of 500 rpm. In this case, the settings should be as follows: 
 

Parameter Value 
Trigger mode Normal 

Acquisition mode Single 
Realtime mode Disabled 
Acquisition time e. g. 510 ms  

(depending on the number of selected tracks and time prescaler value) 
Trigger source Encoder X4X2: Speed 
Trigger slope Rising 
Trigger value 500 [rpm] 

Pre-trigger time 100 [ms] 
 

By pressing the Run/stop acquisition button, the acquisition starts. When the motor is started 
and the speed rises above 500 rpm, the trigger starts and the acquisition is displayed in the 
Graph area (same function as the Start acquisition display button). The acquisition stops after 
510 ms. The resulting curves could be as follows: 

 
 

The yellow cursor shows the trigger point of the motor speed.  
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4.5.7 Import Project from the Target Device 
Depending on the target device you are interfacing with, you are able to upload a working 
AxiaManager Scope project from the target itself. 
In order to upload the project from the target device, follow the procedure below: 
• Click the Acquisition>Import project from target menu, which opens the Target list 

dialog box. 
 

 
 

• From the shown list select the target device from which you want to upload the project. 
• Configure Connection with correct parameters (  3 for more details). 
• You can test the connection with the target device by Verify Connection button. 

AxiaManager Scope tries to establish the connection and reports the test result. 
• If the connection is available confirm the operation by clicking on the Upload Sources 

button. When the application upload completes successfully, the project is open and 
ready for editing. 
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5 Manage AxiaManager Scope Files 
This chapter focuses on AxiaManager Scope files. 
An AxiaManager Scope file (.bse file) includes all the required elements to properly work with 
graphs including all settings needed to run the oscilloscope. 
The following paragraphs explain how to organize the graph files. 
 

5.1 Create a New File 
To start a new project, click ..File>New of the AxiaManager Scope’s menu or click the button 
New acquisition … in the Welcome page (when no project is open). 
 

 
 

This causes a dialog box to appear, which lets you create a new acquisition. 
 

 
 

You are required to select the Axia device from the Device catalog. You can set a filter by 
typing the Axia device you want to select in the Filter field. 
The list of devices depends on the contents of AxiaManager Scope catalog, which contains the 
list of all available devices. 
 

5.2 Open an Existing File 
To open an existing project, click   File>Open of AxiaManager Scope’s menu, or click the 
button Open acquisition …in the Welcome page (when no project is open). This causes a dialog 
box to appear, which lets you load the directory containing the project and select the relative 
project file. 

 
 

This causes a dialog box to appear, which lets you load the directory containing the project 
and select an existing acquisition. 
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5.3 Load Offline Tracks 
Click on File>Load offline tracks… to reload previously stored recordings. The method of 
loading tracks helps you to analyze acquisitions made in other projects or applications. 
To load such files, AxiaManager Scope can be started in stand-alone-mode. 
 

5.4 Save the Acquisition 
When you make any change to the acquisition you are required to save it in order to persist 
that change. To save the file, you can select the corresponding item   File>Save . 
You are required to enter the name of the new acquisition in the Name text area.  
The file suffix of AxiaManager Scope files is .bse. 
 

5.5 Save to an Alternative Location 
You can use the File>Save As … command to rename the file, change its format or modify 
the location of where you want to save the file. 
 

5.6 Close the Acquisition 
You can terminate the working session either by explicitly closing the acquisition or by exiting 
AxiaManager Scope. In both cases, when there are changes not yet persisted to file, 
AxiaManager Scope asks you to choose between saving and discarding them. 

 
 

To close the file, select the item File>Close ; AxiaManager Scope shows the Welcome page, 
so that you can rapidly start a new working session. 
 

5.7 Print the Graph 
Follow this procedure to print a view of the data plotted in the Oscilloscope: 
• Either pause or stop the acquisition. 
• Only the elements included in the view will be printed, so move the time slide bar and 

adjust the zoom, in order to include in the view the elements you want to print. 
• Select the item File>Print Graph…. 
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5.8 Export Tracks 
The Export function enables a data export in different formats. Possible formats are:  

− *.tsv: TSV tab separated file (for data view). 
− *.OSCX: Oscilloscope XML files 

 

You can use the export function to send data for offline analyzation or for further processing 
in different applications, e. g. in Microsoft Excel. 
Click on File> Export tracks… to export the track, change its format and modify the location 
of where you want to save the exported track. 
Click on File> Export tracks (visible samples only)… to save only the visible samples for a 
better focus on the selected view. 
In the menu File> Export tracks options… you can select the separating character for decimals 
and an individual value separator. This makes the data export easier for further processing 
and clearer presentation. 
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6 User Interface Reference 
This chapter lists all functionalities of AxiaManager Scope. It is intended as a reference guide, 
where you can look for functions in the windows, menus and toolbars. 
 

6.1 Using the Output Window 
The Output window is the place where AxiaManager Scope reports its output messages. 
 

 
Reading/writing parameters or polling operations can be logged to show their results in this 
window by selecting Menu > Options > Debug log. 
 

6.2 Using the Watch Window 
Use the Watch window to view READ, WRITE and Application error message reports. 
The Watch window allows you to monitor the current values of a set of objects. Being an 
asynchronous tool, the Watch window does not guarantee synchronization of values. 
Therefore, when reading the values of the variables in the Watch window, be aware of the 
possibility that they may refer to different execution cycles of the corresponding task. 
 

 
 

The information shown includes the PLC symbol, the object name and its value. If the target 
device is disconnected, the Value column contains three dots. 
 

Add objects to the Watch window 
In order to add an object, select it in the Parameters window and drag-and-drop it in the 
Watch window. 
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 Drag-and-drop function 
 

Remove objects from the Watch window 
If you want an object from the Watch window, select it by clicking on its name once, then 
press the Del key. 
 

Read/Write message reports 
The watch function reads the object values periodically. This action is carried out 
asynchronously, so it may be necessary to refresh the value reading by pressing one of these 
buttons: 
 

 
Press this button to read the selected watch item. 

 
Press this button to write the selected watch item. 

 

6.3 Menu Bar Reference 
In the following tables you can see the list of all AxiaManager Scope’s commands. You may 
find some disabled commands or even some unavailable commands if there is no logical 
relation to the active project. 
 

6.3.1 File Menu 
Command Icon Key Description 

New  Ctrl+N Creates a new AxiaManager Scope project. 

Open…  Ctrl+O Opens an existing AxiaManager Scope project. 

Save  Ctrl+S Saves the current open project. 

Save As …   Saves the current open project specifying new name, lo-
cation and extension. 

Close   Closes the open project. 

Load offline tracks…   Lets you load offline track a library to the graph. 

Export tracks…   Lets you export an AxiaManager Scope track to a library. 
Export tracks (visible 
samples only)   Lets you export the visible samples of an AxiaManager 

Scope track to a library. 
Export tracks options…   Opens the Export tracks options window. 
Print graph…  Ctrl+P Prints the currently active graphs. 
Exit   Closes AxiaManager Scope. 
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6.3.2 Edit Menu 
Command Icon Key Description 

Remove selected track DEL Deletes the selected track from the graph. 

Add custom track Ctrl+T Adds a custom track to the graph. 
Remove all trigger 
source tracks Removes all trigger source tracks from the graph. 

6.3.3 View Menu 
Command Icon Key Description 

Output Shows or hides the Output window. 
Graph controls Shows or hides the Graph controls window. 
Acquisition control Shows or hides the Acquisition control window. 
PLC Symbols Shows or hides the PLC Symbols panel. 
Parameters Shows or hides the Parameters panel. 
Watch window Shows or hides the Watch window. 
Main toolbar Shows or hides the Main toolbar. 
Status Bar Shows or hides the Status bar. 

6.3.4 On-line Menu 
Command Icon Key Description 

Set up 
communication... F12 Lets you set the properties of the connection to the tar-

get. 

Connect F11 AxiaManager Scope tries to establish a connection to the 
target. 

6.3.5 Acquisition Menu 
Command Icon Key Description 

Run acquisition F3 Starts the track acquisition. 
Stop acquisition F4 Stops the track acquisition. 
Download last 
acquisition F5 Lets you download your last acquisition. 

Pause acquisition F6 Lets you pause the track acquisition. 
Continuous capture Selects the acquisition mode Continuous capture. 
Single sequence 
capture Selects the acquisition mode Single sequence capture. 

Auto trigger mode Selects the Auto trigger mode. 
Normal trigger mode Selects the Normal trigger mode. 
Force trigger Selects the Force trigger function. 
Import project from 
target Reloads all remote logs from target. 
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6.3.6 Graph Menu 
Command Icon Key Description 

Toggle grid   Choose whether to display or not the Toggle grid in the 
oscilloscope window. 

Dynamic grid   Activate/deactivate the dynamic grid function in the oscil-
loscope window 

Show measure bars   Show or hide measure bars in the oscilloscope window. 

Show acquisitions   Highlight the single values detected during data acquisi-
tion 

Vertical split   Split the graph view to show the graphs in single win-
dows. 

Undo zoom settings   Reverse the latest changes of the zoom view. 

Show all values   Force the oscilloscope to display all samples for both hor-
izontal and vertical axis. 

Show all values for 
selected track   Force the oscilloscope to display the samples of a single 

track. 

Horizontal zoom in  
Ctrl+Shift+ 
F12 Zoom in for in horizontal axis. 

Horizontal zoom out   Zoom out in horizontal axis. 

Horizontal show all  Ctr+  Show all samples in horizontal axis. 

Vertical zoom in  Ctrl+  Zoom in for in vertical axis. 

Vertical zoom out  
Ctrl+Shift+
 Zoom out in vertical axis.. 

Vertical show all  Ctrl+ ⬆ Show all samples in vertical axis. 
 

6.3.7 Options Menu 
Command Icon Key Description 

Change language…   
Open the Select Language menu. You can change the 
language of the environment by selecting a new one 
from the list shown in this panel. 

Debug log   Opens a dialog where you can select the types of logs to 
be listed in the Output window. 

 

6.3.8 Help Menu 
Command Icon Key Description 

About...   Credits and version information. 
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6.4 Main Toolbar Reference 
In the following tables you can see the list of all AxiaManager Scope’s toolbars. The buttons 
making up each toolbar are always the same, whatever the currently active document. 
However, some of them may produce no effect if there is no logical relation to the active 
document. 
 

 
Icon Command Description 

 New Creates a new AxiaManager project. 

 Open… Opens an existing AxiaManager project. 

 Save  Saves the current open project. 

 Save As … Saves the current open project specifying new name, location and 
extension. 

 Load offline tracks Lets you load offline track a library to the graph. 

 Remove selected tracks Deletes the selected track from the graph. 

 Add custom track Adds a custom track to the graph. 

 Connect AxiaManager Scope tries to establish a connection to the target. 

 Communication settings Lets you set the properties of the connection to the target. 

 Open function editor Opens the current project in AxiaManager PLC. This enables you to take 
the sources of the selected tracks and modify them in the AxiaManager 
PLC. The modified sources are directly usable after returning back to 
AxiaManager Scope. 
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7 Run AxiaManager Scope via command prompt 
It is possible to start AxiaManager Scope in batch script (unattended mode) if you follow these 
steps: 

1. Configure Acquisition Settings:
• Start AxiaManager Scope and open an existing .bse file.

Or:
• Configure a new acquisition with the necessary settings (e.g., inverter communication,

channels, etc.).
• Test the acquisition to ensure it works as expected.
• Save the current project to a .bse file.

2. Run AxiaManager Scope from a command prompt:
• Open a command prompt (cmd.exe).
• Use the following commands:

AxiaManagerScope.exe "C:\Users\Public\Desktop\batch.bse" 1

/DOWNLOADDATA
/EXPORTTRACKS:"C:\Users\All\Public\batch.csv"
/SAVE

Where:
− The first argument is the .bse file path containing the acquisition settings. This is

mandatory.
Remember to adjust the file path and file name according to your specific setup.

− /DOWNLOADDATA automatically triggers record and playback without any user inter-
action. This is mandatory.

− /EXPORTTRACKS:"filename.csv" specifies the CSV file to download extracted data.
This is optional.

− /SAVE saves the .bse file again. This is optional.

1 Replace "C:\Users\Public\Desktop\batch.bse" with the actual path to your saved .bse file. 
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